[freeside] Freeside-RT integration issues (Follow-up)

Shivkumar shivkumar at outbackwifi.com
Thu May 12 03:40:39 PDT 2005

like they say it gets "curiouser and curiouser!"
i downloaded a tar ball of the latest rt (3.4.1), untarred it and did
#./configure --with-db-type=Pg
#make testdeps
make fixdeps
#make install
#make initialize-database
the whole thing worked like a charm. no more "Strange things are afoot 
at the circle K" errors
btw the DBD was DBD-Pg-1.41_1! (there goes the advise in the wiki)
however i have run into other problems with gettting the whole thing to 
work independently
like no login fields on the index page!
ill try to sort these out and then try to copy all the non-freeside 
specific files into the freeside tree and try make create-rt again.



Shivkumar said the following:

> hi,
> Ive installed Freeside v1.5.0pre6 CVS dated 21 April 05 on a Solaris 8
> sun-sparc machine.
> I am now trying to integrate the RT (request tracker) module.
> as per the instructions given,
> I edit top-level Makefile and enable RT
> Install all the required perl modules thro CPAN
> Created the group rt
> #make configure-rt
> no errors
> #make create-rt
> dies with this error
> rt/sbin/rt-setup-database --action insert_initial \
> && rt/sbin/rt-setup-database --action insert --datafile 
> /opt/rt3/etc/initialdata \
> || true
> Checking for existing system user...not found.  This appears to be a 
> new installation.
> Creating system user...[Wed May 11 03:37:45 2005] [crit]: Couldn't 
> create a Principal on new user create. Strange things are afoot at the 
> circle K (/opt/rt3/lib/RT/User_Overlay.pm:479)
> Could not create user
> I have looked at the RT wiki at bestpratical.
> there is a mention of this error occuring with DBD-Pg- > 1.40
> They recommend installing DBD-Pg-1.32
> Just for kicks, I installed DBD-Pg-1.32 from source (I already have 
> DBD-Pg-1.41_1)
> and again ran make create-rt.
> I still am getting the same error.
> So what gives?

More information about the freeside-users mailing list