[freeside-users] Auto-suspend unsuspend loop

Daniel Feliciano Branco daniel at bluetopia.biz
Mon May 10 05:25:11 PDT 2010


 I've been using freeside 1.7.4rc2, installed from the freeside .deb
repos, on a up to-date debian 5 since it was release without any problems.
But when I've tried to add a new service definition it hanged on the
javascript progress bar without adding the service.

 To try to solve the issue I've then moved to a more stable release and
installed a new and updated debian 5, .deb packages from freeside debian
install, installed 1.7.4 from source and migrated the confs and db to it,
that solved the issue, but led to a new one, when I try to unsuspend a
costumer package, the refreshed page lists it as active, but if I bill it
or refresh the page it's listed suspend again.

 To try to solve the issue, I saw a new conf option
"cust_pkg-show_autosuspend" on the 1.9.3 release, so I did a new debian 5,
freeside 1.9.3 from source install, copied and migrated the confs/db and it
looks good, but the auto-suspend unsuspend loop remains. Now I have a
"Change History" that lists "job queue" auto suspending the packages 2
seconds after I unsuspended it.

 I don't think it's a bug, but probably some configuration issue on my
part, or some thing that got lost on the migration. What puzzles me is that
if I go back to my 1.7.4rc2 install, the unsuspend works as expected. Can
any one point me to where search for a solution? Thanks in advance.
 I'm sorry for the list of problems, if it was a list of "it worked fine"
it would much longer and repetitive. ;-)

 Thanks again

Daniel Feliciano Branco
Bluetopia Open Source Solutions

More information about the freeside-users mailing list