[freeside-users] table error / uninstall procedure

John (yt) Hogenmiller ytjohn at gmail.com
Mon Oct 30 16:42:21 PST 2006


I have been testing first freeside 1.5.8, then I installed Freeside
1.7.0 from cvs.  After a weeks worth of experimenting with 1.7.0, I
decided that I would stick with 1.5.8.

I attempted to remove the installed files, including the perl modules,
dropped the database, and re-installed.  Things looked good until I
went to the part of the initial configuration where you create a

I made a svc_domain, viewed packages (none yet) and clicked to create a package.

I then get this error:

error:   	Illegal table: at
/usr/local/lib/perl5/site_perl/5.8.8/FS/Record.pm line 246.
242:  	}
244:  	#$stable =~ /^([\w\_]+)$/ or die "Illegal table: $table";
245:  	#for jsearch
246:  	$stable =~ /^([\w\s\(\)\.\,\=]+)$/ or die "Illegal table: $stable";
247:  	$stable = $1;
248:  	my $dbh = dbh;
250:  	my $table = $cache ? $cache->table : $stable;
code stack:  	/usr/local/lib/perl5/site_perl/5.8.8/FS/Record.pm:246

I checked -- the part_pkg table does exist in the postgres database.
I then moved the FS directory (and FS.pm) files out of the perl tree
and did  a "make install-perl-modules" to make sure that the FS 1.5.8
files were in place, but I still got the same error.

I've tried looking several places for anything that FS 1.7.0 would put
in place that I didn't get rid of.  If anyone has a method for
completely ripping freeside (1.7) out of the system so I can do a
clean install, I can try that.

On the other hand, if there is a fix for the error, I'll take that too.

My only other option is deleting the jail and re-creating it, which
involves reinstalling all of the perl/cpan modules -- something I am
hoping to avoid, as I have done it three times already in testing this


YourTech, LLC - http://yourtech.us/
(this account is used for mailing lists)

More information about the freeside-users mailing list