Norman Strampach strampach at
Sun Mar 24 19:20:56 PST 2002

I'm having difficulty with an error message coming up when I try to access 
the admin links.  For instance I get :

Forbidden You don't have permission to access /freeside/browse/part_svc.cgi 
on this server.

I also get a message in /var/log/httpd/error_log indicating I don't have 
ExecCGI on (I do!).  I've followed the installation with a MySql database.  
The only think that I haven't done is run Apache with mod_perl enabled as the 
freeside user.  How do I do that anyway?  

I'm using the standard Mandrake 8.1 with Kernel 2.4.8-26mdk on an i686
the server is  Apache-AdvancedExtranetServer/1.3.20 (Mandrake Linux/3mdk)

Loaded Modules (from info.php3)
mod_vhost_alias, mod_ssl, mod_php4, mod_setenvif, mod_so, mod_usertrack, 
mod_headers, mod_expires, mod_digest, mod_auth_anon, mod_auth, mod_access, 
mod_rewrite, mod_alias, mod_proxy, mod_userdir, mod_actions, mod_imap, 
mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_info, mod_status, 
mod_negotiation, mod_mime, mod_log_referer, mod_log_agent, mod_log_config, 
mod_env, http_core

I notice from the above that mod_perl isn't listed but I can get other perl 
(.pl) scripts to work (in other directories) although not with the 
HMTL::Mason module.

Has anyone experienced and solved this type of problem previously?  If I 
could get some idea of what needs to be done it would help.  I've included a 
previous message from the freeside list that appeared to be connected but was 
not helpful in this case.


----- Forwarded message from Ivan Kohler <ivan> -----

Date: Fri, 6 Nov 1998 22:37:46 -0500
From: Ivan Kohler <ivan>
To: tanto <tanto at>
Subject: Re: Good news.

On Fri, Nov 06, 1998 at 10:20:14PM +0200, tanto wrote:
> I finally was able to get freeside working on my machine (upgraded to
> FS-1.1.5).  The problem seemed to lie in Apache 1.3.1.  It was giving me
> the following error message:
> [Fri Nov  6 19:19:13 1998] [error] Options ExecCGI is off in this
> directory: /usr/local/apache/htdocs/freeside/edit/cust_main.cgi
> Even though ExecCGI was on (and I followed all of your installation steps 
> exactly). I tried this on my Apache 1.3.3 webserver and it worked fine.. I
> should have used it on the 1.3.3 server earlier.  Note: I am running
> Apache as "freeside".

Thanks for the tip.  Strange I never noticed that, as I should track
Apache versions pretty closely (running Debian unstable).

More information about the freeside-users mailing list