[freeside] Re: Pg Error when trying to unsuspend a customer's package

ivan at 420.am ivan at 420.am
Fri May 30 02:48:13 PDT 2003

On Thu, May 08, 2003 at 10:45:46PM +0000, scott at ruralnetwork.net wrote:
> Of further note: 
> The first time I run 'make aspdocs' it stops with the error: 
> make: *** No rule to make target `httemplate/*/*/*/*', needed by `aspdocs'. 
> Stop. 
> Then, the second time I run 'make aspdocs' it completes successfully. 


> When I follow the instructions on the Freeside Administration document to: 
> "First, it is necessary to create a domain definition. Click on View/Edit 
> service definitions and Add a new service definition with Table  svc_domain 
> (and no modifiers)." 
> This doesn't add a corresponding record to the Pg table svc_domain.  

That's later in the instructions:

- Add your own domain

> Therefore, I cannot add a new service definition that requires a domsvc 
> value.  (That is, the drop down list box for selecting a domain is empty). 

That's not listed in the instructions until after you add a domain.

> A workaround is to manually create a record for the domain definition in 
> the database table svc_domain.

I don't think a workaround is required.  Documentation patches
appriciated if you don't find it clear, but as far as I can tell you
should have simply followed all steps in the instructions in order.

> And I'm not sure what goes in the 'catchall' field for that table. 

Some exports use this field to specify the catchall email destination
for a domain.  This might change in 1.5.

> If I want to export to the latest freeradius server (version 0.8.1), which 
> I do, I have to modify the code in FS/part_export/sqlradius.pm to set the 
> op fields to correct values because this version of freeradius REALLY 
> doesn't like null op field values. 

Applied.  If anyone is still using a schema without "op" fields, speak
up soon and I'll make it an export option.

> Under Mandrake, I'll often get these errors for ssh exports like: 
> FS::part_export::shellcommands::ssh_cmd  	user root host 
> command useradd -c '' -d / -s /bin/false... stdin_string  	Thu May 8 
> 11:54:52 2003  failed: [Net:SSH::ssh_cmd] STDERR Warning: No xauth 
> 	data; using fake authentication data for X11 forwarding. ( retry | remove ) 
> The work-around I use is to modify the Mandrake defaults for X11 forwarding 
> for the ssh daemons from yes to no. 
> Before work-around: 
> /etc/ssh/ssh_config:
> ForwardX11 yes 
> /etc/ssh/sshd_config:
> X11Forwarding yes 
> After work-around: 
> /etc/ssh/ssh_config
> ForwardX11 no 
> /etc/ssh/sshd_config:
> X11Forwarding no 

Documentation updated (~root/ssh/config is a better place to edit).


More information about the freeside-users mailing list