[freeside] initial config saves some of the values?

Randall Lucas rlucas at tercent.net
Mon Jun 23 15:23:34 PDT 2003

On Sunday, June 22, 2003, at 09:51 AM, ivan at 420.am wrote:

> On Wed, Jun 18, 2003 at 11:53:22AM -0400, Tony Carter wrote:
>> -----Original Message-----
>> From: Andrew Furey [mailto:andrew at terminus.net.au]
>> Sent: Wednesday, June 18, 2003 1:35 AM
>> To: ivan-freeside at sisd.com
>> Subject: Re: [freeside] initial config saves some of the values?
>>> When I try to perform initial configuration of our installation, 
>>> some of
>> the
>>> values are saved and some are not. Subsequent attempts clears some 
>>> of the
>>> previously saved data.
>>> Has anyone seen this before?
>>>> You mean the values like invoice templates, shells, SMTP machine, 
>>>> etc? I
>>>> think I had the same problem with my installation (similar 
>>>> versions).
>>>> The values are set in the text files in the install location (in my 
>>>> case
>>>> /usr/local/etc/freeside), in the conf.[blah] directory. I think in 
>>>> the
>>>> end I just set them one value at a time (they usually seemed to 
>>>> save the
>>>> very first time), then changed the permissions on the resulting 
>>>> file so
>>>> it couldn't edit it again. Definitely not the way it should work, 
>>>> but it
>>>> did the job.
>>>> HTH
>>>> Andrew
>> Thanks Andrew,
>> Your workaround does sound like it will work but I'm more interested 
>> in
>> finding a real fix so that we can use the interface to change the 
>> config.
>> Has anyone else ran into this problem before?
> I've never been able to duplicate the problem.
>> Any pointers to troubleshooting this?
> Something along the way is truncating the large amount of form data.
> Browser? Proxy? Web server?  Dissect the HTTP transaction and find out.
> I'd be interesting in useful additional information.
> -- 
> _ivan

I've had this problem as well on a Red Hat 8 box with a FS 1.40 
install.  For example, just today I was playing around on a testing 
box, trying to get emailing of invoices to work, when I noticed that 
"smtpmachine" wasn't set.  So, I used the Web interface to alter the 
value, and when I saved it, it didn't save the smtpmachine value but it 
did wipe out my "business-onlinepayment" setting and gave this message 
to the Apache error log:

[FS::Conf] DELETE business-onlinepayment
[FS::Conf] SET report_template

I then tried to set business-onlinepayment from the Web interface; 
wouldn't take.  So I created a file, saved it, and the Web interface 
showed the new value.  However, using the Edit functionality in an 
attempt to add the smtpmachine caused it to fail again, this time 
making the following error log notation:

[FS::Conf] DELETE smtpmachine
[FS::Conf] DELETE business-onlinepayment

Tres odd. I then noticed that the only items getting saved (only files 
which survive in the conf dir) are:


If you'll notice, those are the first five on the form.  I put a 
CGI::Dump call into the config-process.cgi, and sure enough, CGI is 
only finding out about the input up to report_template.  Fishy, because 
this is a POST request and the max size should be WAY bigger than this.

But, woe of woes, when I tried to get this behavior to repeat a third 
time, it started working fine, and passing all the vars along.  It 
seems fairly consistent that 1/5 or so times, I can pass all the CGI 
params in OK but the rest of the time anything after report_template 
does NOT get passed through to the CGI object and consequently is 

*The major note to this is I am using mod_perl 1.99 / Apache 2 on this 
testing box.

Of the others who've had conf script troubles, what is your os/fs 
version/apache version/mod_perl version?  Can you check to see what's 
coming through on the request?



More information about the freeside-users mailing list